Announcement

Collapse
No announcement yet.

iwconfig/wpasupplicant / adding files to Roms

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iwconfig/wpasupplicant / adding files to Roms

    Hi,

    iam trying to change/add files in my rom using the tools provided in Uten 4K - Need help dumping the Rom Thread

    No matter what file I add or change, the cam always boot loops flashing it. Not matter if I used Phoenix or flashed via SDCard.

    I especially like to connect the cam to my wifi network in order to remote control it/ download pictures.

    As far as i can tell does the rom not include any software necessary to connect to networks instead of hosting them.

    The binaries for wpasupplicant and iwconfig are missing and running them from sd card just gives error about the system partition being read only.
    I for example modified \etc\wifi\wpa_supplicant.conf to include my network credentials.

    I added/modified files in the uncrompressed squashfs-root folder and then used squashfs_make.bat.
    I then run and refex and flashed the rom.

    The cam then boots to the boot screen, shows it for a moment and restarts. It is not possible to connect via adb during this time.

    My question now is, How to properly modify files? I think changing few lines in the wpa_supplicant file should not cause boot loops.

    I also tried different other roms that included iwconfig but they booted just to a white screen.

    Thank you

    Flaep



    PS: Iam one Year goprawn member tomorow xD






    Hi, it recently purchased a Uten 4k and struggle to dump the ROM. It appear like the dd executable is not Part of the FW. The overall behaviour is strange. I can download any file from the filesystem by pointing a browser to it. If I connect to the cam via wifi and for open "http://192.168.100.1/system/etc/settings.xml&quo

  • #2

    if you are using the UNFEX script, you can simply unscrew and then compile again that will go into loops anyway, on page 2 something about cygwin it worked for me

    Comment


    • petesimon
      petesimon commented
      Editing a comment
      flaep
      No matter what file I add or change, the cam always boot loops flashing it. Not matter if I used Phoenix or flashed via SDCard.
      boot loops can happen for different reasons. one main reason is that you used 'squashfs_make.bat' script in Windows to make a new '2-system.img' file. Among other reasons, this causes a boot loop. Use Cygwin in Windows or use Unix/Linux instead.

      nutsey wrote "Warning: If you get a boot loop after flashing repacked firmware try to pack 2-system.img in Cygwin. Details are here."

      go to post #154 and go to comment #154.6 (expand all comments). https://www.goprawn.com/forum/allwin...=2578#post2578

      also see this other thread https://www.goprawn.com/forum/allwin...m-img#post2735
Working...
X