Announcement

Collapse
No announcement yet.

WiFi not working on XDV camera.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WiFi not working on XDV camera.

    Hello. I have a XDV 4K 16MP WiFi sports camera. The specs on the box say:
    Image sensor: sony 179
    LCD: 2" LCD panel
    Firmware version: 20170406V3.3

    Right now now the WiFi does not work and I was wondering if I need to update/change the firmware to get it to work, and which firmware I should update to.
    Here is a backup of the current firmware: https://www.dropbox.com/s/2prlwqe9ep...ackup.zip?dl=0

    Thanks

  • #2
    same problem here not wifi andoer fuxin (andoer logo) 4k 20160912(lost original)make update to 2017 03 02(skylogo)and working perfect but no wifi. dosen't show up in any device wifi list . antenna inside is fine. any help?

    Comment


    • petesimon
      petesimon commented
      Editing a comment
      bolo1972 - there are two known wifi drivers in firmware -- "8189" and "xradio". and the xradio is marked by a small " Ⓧ ". but the 8189 is not marked at all. if the firmware you tried has one wifi driver, then try firmware that has the other wifi driver.

      also read the next post #3 below...

  • #3
    Greenthunder - if your camera's original firmware does not let the wifi work, then there maybe some other problem in the camera. The wifi driver in the firmware is "xradio". So you need to find other firmware that also has a xradio driver. This is marked by a small " Ⓧ " symbol on page 1 in post #8 here. You can try other firmware under "Sony IMX179s sensor" that has the Ⓧ symbol and has the same LCD screen. For example, you could try this one IMX179s "Fuxin (andoer boot logo) 2017-03-02 (shows 20170213 V23) Ⓧ" ... but I don't know if it works for your camera. You just have to experiment.

    firmware info from backup.zip that you shared here:
    Code:
    SoC:  
       Allwinner V3 
    Product:  
       cst179s-sdv
    Manufacturer:  
       yj
    Short id:  
       chuangshitong
    OEM id:  
       welcome
    Camera type:  
       lp6182
    FW orig. date:  
       20170304
    FW mod. date:  
       20170406
    Camera name:  
           ?
    Version:  
       20170406V3.3
    LCD model:  
       st7789v
    LCD resolution:  
       320x240  
    LCD count:  
       1
    Sensor model:  
       imx179s
    Logo:
       BYE BYE / WELCOME (street)
    Wifi:
       xradio

    Comment


    • #4
      Thanks petesimon. I brought the camera back to the store I bought it from and we tried 3 or 4 different camera's and none of the Wifi worked on any of them! Is it possible that the Wifi is not xradio? Should I try one with the other Wifi driver?

      Thanks.

      Comment


      • petesimon
        petesimon commented
        Editing a comment
        Is it possible that the Wifi is not xradio?
        yes. see comment #2.1 above.
        yes. try other firmware that has other wifi driver

    • #5
      Ok, so I flashed this firmware: cst-imx179s-20160929, and the Wifi works now, thanks for the help. The firmware originally on the camera had the wrong radio type.
      Just curious, what is the CST and Fuxin, Crane, etc., is that the firmware manufacturer? Would there be any reason for me to try one of the other ones?

      Thanks.

      Comment


      • petesimon
        petesimon commented
        Editing a comment
        CST, Crane, Fuxin, etc are possibly the makers of the internal motherboard and/or the firmware. I just think of it as the "flavor" of the camera....
        Uknow...like ice cream is ice cream but there are different flavors

    • #6
      Originally posted by Greenthunder View Post
      Ok, so I flashed this firmware: cst-imx179s-20160929, and the Wifi works now, thanks for the help. The firmware originally on the camera had the wrong radio type.
      Just curious, what is the CST and Fuxin, Crane, etc., is that the firmware manufacturer? Would there be any reason for me to try one of the other ones?

      Thanks.
      I just found this post today, and have the same issue with wifi - I can't find any instructions on how to flash the camera, or where to download firmware. Can you help me out at all?
      Thanks!

      Comment

    Working...
    X