Announcement

Collapse
No announcement yet.

Help modifying system.img adding Wifi drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help modifying system.img adding Wifi drivers

    Hello all,

    May I ask anyone to do a System.img modification for me? For the life of me, I just couldn't do it without bricking my camera, this is on a Windows 10 Pro x64bit and using all the UNFEX scripts that I've found from MD or Nutsey?

    Basically, I would like this FW 20170602V6.0(OV4689 + ST7789/v + xCore?) to work with my wifi module 8189:
    https://drive.google.com/file/d/10kY...ew?usp=sharing

    Fortunately, pulling the script.bin from this FW 20160408V4.0(OV4689 + ST9341 + 8189) makes the above firmware work, but without WIFI, hence the need of the modification above:
    https://drive.google.com/file/d/1oMw...ew?usp=sharing

    So far, I've tried putting the 8189.ko and removing the xcore drivers from the module folder. I can compile to system.img alright, then refex it, then change the script.bin, then convert it to img to flash with Phoenix Suit, but the camera just freezes on bootup screen without even doing the bootup sound. So I'm not entirely sure what I did wrong.

    Even simple modification to the system.img of the old FW bricks the camera, this is to just change the name of the firmware that shows up in the camera. So I assumed, it is not compiling to the system.img properly.

    Basically, whats needing to be done (based on what I know) on the most recent system.img are these:
    - Remove xCore(s) wifi drivers
    - add 8189.ko
    - (not entirely sure if these are necessary) copy wpa and wpa_cli from old FW to new FW, found on etc folder (if memory serves me right).

    My camera details are in my sig below.

    If anyone could do this for me, I would really appreciate it.

    P.S.
    I compared their boot.img via extracting them, they seem to be identical. all inits are the same.

    P.P.S.
    Is there another method to add wifi drivers on FWs?

    Thank you all
    Last edited by Skanob; 02-08-2018, 01:36 PM.
    Elephone ELE Explorer 4K UItra HD WiFi Action Camera - Black (Original FW 20160408V4.0) (wasn't able to do a backup of FW )
    Omnivision OV4689 + ST9341 Display + 8189 WiFi

  • #2
    Hey which method are you using to recompile system.img? For this camera you have to do it manually through cygwin, otherwise it wont boot

    Comment


    • #3
      Originally posted by Boompje View Post
      Hey which method are you using to recompile system.img? For this camera you have to do it manually through cygwin, otherwise it wont boot
      I see. Have you got any guide for that?

      If it is not too much to ask, do you adding the wifi drivers for me? You can try following what I'm trying to do in the OP.

      Cheers mate.
      Elephone ELE Explorer 4K UItra HD WiFi Action Camera - Black (Original FW 20160408V4.0) (wasn't able to do a backup of FW )
      Omnivision OV4689 + ST9341 Display + 8189 WiFi

      Comment


    • #4
      And we never heard from him again... (hate it when that happens)

      Comment


      • petesimon
        petesimon commented
        Editing a comment
        heard from who?
    Working...
    X