Announcement

Collapse
No announcement yet.

MG COOL Explorer Pro only show mgcool logo

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MG COOL Explorer Pro only show mgcool logo

    Hi guys. Im a new member in our comunity.
    I have been searching some info about unbrick my cam (allwinner v3, imx 179)
    I buyed in gearbest, and arrived deffective. The camera dont start, only show "MGCOOL" logo.
    Id like to know how i can recivery it
    I´ve tried to install drivers, recovery drivers and Phoenix.
    Apparently Phoenix install the firmware but only can show mg cool logo again. Some idea? Thanks!

  • #2
    howdy, and welcome. What computer OS are you using -- Windows 7 or 8 or 10 ? Did you disable "windows disable driver signature enforcement" ? * Do this first! *

    Click image for larger version  Name:	driversigningenforcement.png Views:	1 Size:	27.7 KB ID:	9177

    After that, you can look for firmware on page 1 in post #8 ( link here ) for a file that can work. I suppose you can first try the firmware that has MGCOOL logo under "Sony IMX179 sensor" heading. But realize that there is so much different hardware in the many Allwinner cameras, so you may have to just flash different firmware for different sensor / SoC (chip) / Product (such as Crane) to find firmware that works.

    Watch this tutorial at TIME 13:50 - https://youtu.be/QrTxFjIiHvc?t=830 - and download all necessary tools and drivers from this link http://bit.ly/2h19sjr (shown in the description box of the video). Recovery drivers in "PhoenixSuit_Drivers.zip" file available from this online folder ( link here ) work for me in Windows 10 release 1709 and they might work for you too.

    Good luck. Cheers.
    Last edited by petesimon; 02-14-2018, 04:34 PM.

    Comment


    • #3
      This happened to my MGcool camera as well.
      The problem was a hardware failure. There is a very small resister soldered onto the edge of the PCB right next to the top button. It just so happens that when the camera was assembled, this resistor was nudged and the trace broke. Pressing really hard on the top panel allowed the camera to boot and work, but letting go would cause it to hang on video, or not boot.
      I tried to solder the resister back, but the traces are microscopic, so it's now a brick.

      Comment

      Working...
      X