Announcement

Collapse
No announcement yet.

Xiaomi Yi 1.5.6 fw for all hw revisions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xiaomi Yi 1.5.6 fw for all hw revisions

    221, 231, 23A, 23S
    22L, 23L
    25L
    26L

    Unpack, rename to 'firmware.bin' and put to the root of your memory card.

  • #2
    is this safe/tested and working f/w?

    Comment


    • nutsey
      nutsey commented
      Editing a comment
      Yep. I successfully updated my Z22 cam, other versions are also reported to work at 4pda.ru forum.

    • flatline
      flatline commented
      Editing a comment
      worked on my Z26L too. let's try yimax script

  • #3
    So finally... I got to update my Yis too. Might be the final firmware for all Yi action cams I guess.
    I'm sorry that I couldn't test scripts the last days. There wasn't sun at all here an I've been busy too.

    Comment


    • #4
      1.5.6, Z26L. Pink photo. Everything is done according to the instructions. It seems like I've been told that this method for SONY matrix and need for Panasonic.

      Comment


    • #5
      There seem to be some changes in 1.5.6 when it comes to scripting. I just made a memory dump to look into.

      Bitrate table and resolutions are shifted again. Setting the video mode with "writeb 0xC06D4426 0xXX" does still work.
      Last edited by ZeroFPV; 01-18-2017, 09:28 AM.

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        0xC03AB4A0

      • ZeroFPV
        ZeroFPV commented
        Editing a comment
        :-D
        Ok. I'll make updated textfiles for 1.5.6. and attach them to the other thread.

      • MacGyver
        MacGyver commented
        Editing a comment
        Is there's any superview + flat color script for fw 1.5.6 z26L ??

    • #6
      Hello
      I'm owner of a Z25L model and currently i have the firmware V1.2.13 so i can run scripts.
      I use the XIMODE 2.1.0, is a script with many scripts including your's nutsey.
      If i install the v1.5.6 can i use those scripts ?
      Thanks in advance.

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        Hi. 1.5.6 firmware has somewhat different memory structure, so if you want to use bitrate, 4gb limit or superview related script features you need to use updated scripts (I posted them before). And by the way I have nothing to do with XIMODE

    • #7
      I've received my Xiaomi Yi Camera today (brand new) and it came like this:

      https://www.youtube.com/watch?v=KkcP_qN84U8

      What can I do?

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        Have you tried to put a microsd card in?

    • #8
      Yes I have

      Comment


      • #9
        Recovery kit for bricked Z26L Yi cams: https://drive.google.com/file/d/0B4t...ew?usp=sharing

        Comment


        • TwoBlues
          TwoBlues commented
          Editing a comment
          Is there a recovery kit for a z231...?

      • #10
        Upg done on my l26, many tnks

        Comment


        • #11
          Hey Nutsey,
          I have a Z25L version of the Xiaomi Yi with the stock firmware (I believe it's 1.4.3), and I want to improve the quality of the image.
          Is it possible to run the Yimax Pro script on the Z25L version of the camera with 1.5.6 firmware version? I would like to know this before I ruin the camera, or change the firmware without being able to improve the quality as I also can't find the 1.4.3. firmware to undo the changes in case it doesn't work. Can you, or anyone else who knows, help me out with this please? BTW, a different script that will increase the bitrate is fine too! I have used the Waffle script on my old Yi and was very happy with it, but this one doesn't work either.
          Thanks in advance!

          Comment


          • nutsey
            nutsey commented
            Editing a comment
            Hey Darko,
            Try this script to backup your original firmware: https://drive.google.com/file/d/0B4t...ew?usp=sharing

            Put it to a memory card, turn on your cam, wait until the camera switches off, fw will be saved to backup.bin file.

            Note: You will not get flashable file with this script. It only saves all the partitions of firmware into one file. There is still a need to reconstruct the header in order it can be flashed from memory card.
            Last edited by nutsey; 02-22-2017, 06:29 AM.

        • #12
          This FW bricked mine 25L.

          Now it behaves like this:
          https://www.youtube.com/watch?v=BdFhBZlNFSs
          Tried to reflash it with yiActionCamUSB app, but after 5secs (not 50+) it says "Done", but no progress...
          I can see it does something (generates folders and files on the uSD), but still keeps restarting.
          Last edited by DigY; 04-01-2017, 09:23 AM.

          Comment


          • DigY
            DigY commented
            Editing a comment
            The one from your first post for 25L or one I got from Xiaomi Tech.

            Update:
            With AmbaUSB installed, the HW is found as board 3.2.1.0.

            A7L selected (the program recognized it as A7La).
            Messages from AmbaUSB:
            2017-04-01-21:35:28.763: amba_usb_dram_session.cpp[ 274]: Start writing to 0xc00a0000, data size 0000e820!
            2017-04-01-21:35:44.644: amba_usb_dram_session.cpp[ 274]: Start writing to 0xc0000000, data size 00023330!
            2017-04-01-21:36:21.720: amba_usb_dram_session.cpp[ 160]: Jumpping to address c0000000
            2017-04-01-21:36:22.045: amba_usb_device_monitor_win32.cpp[ 89]: \\?\USB#VID_4255&PID_xxxxxxxxxxxxxxxxxxxxxxxxxxxxx xxxxxxxxxxxx}
            2017-04-01-21:36:22.304: amba_usb_data_model.cpp[ 832]: Amba USB device BusID#003.DevID#009 is removed
            2017-04-01-21:36:22.304: amba_usb_data_model.cpp[ 835]: BusID#003.DevID#009 status is Init Board Done
            2017-04-01-21:36:22.306: amba_usb_dram_session.cpp[ 66]: Initialize BusID#003.DevID#009 successfully!

            Then I had to disconnect/turn off the camera and restart with all buttons pressed... next messages

            2017-04-01-21:48:02.715: amba_usb_data_model.cpp[ 916]: HAL file is ambhal.bin, BLD is bld.bin!
            2017-04-01-21:48:02.715: amba_usb_data_model.cpp[ 920]: BusID#003.DevID#010's DRAM start address is 0xc0000000, memfwprog addr is 0xc0100000
            2017-04-01-21:48:02.882: amba_usb_firmware_session.cpp[ 346]: BusID#003.DevID#010 is ready to receive data!
            2017-04-01-21:48:03.286: amba_usb_firmware_session.cpp[ 359]: BusID#003.DevID#010 is about to receive data!
            2017-04-01-21:48:03.287: amba_usb_firmware_session.cpp[ 219]: BusID#003.DevID#010 starts to receive data!
            2017-04-01-21:48:06.965: amba_usb_firmware_session.cpp[ 102]: BusID#003.DevID#010 Transfer finished successfully!

            Then the program waits for reboot, but the camera does not reboot and message:
            2017-04-01-21:54:25.136: amba_usb_firmware_session.cpp[ 158]: Waiting for reboot of BusID#003.DevID#012 timeout!

            disconnecting form PC aborts programming...
            Last edited by DigY; 04-01-2017, 07:55 PM.

          • nutsey
            nutsey commented
            Editing a comment
            I see. The firmware I posted here was flashed with success by dozens of users.
            What steps do you perform when flashing it via USB?

          • DigY
            DigY commented
            Editing a comment
            1. disassembly front panel of the camera
            2. run the program
            3. selecting A7L
            4. selecting the FW
            5. connect the cam to PC (no battery and no uSD)
            6. short the resistor to GND
            7. Turn on camera (keeping resistor shorted) - by pressing the power button
            8. after 1-2secs, remove the shorting wire
            8. Press download.
            9. after the message: Initialize BusID#003.DevID#009 successfully! I have to disconnect the cam from PC and reconnect. And turn on with all buttons pressed (it seems it goes to a mode that is visible to the program). Then the program automatically continues the programming until a message: Transfer finished successfully! Near the progress bar it is written: Waiting for reboot. But nothing happens...

            Pressing any button does not help, disconnecting from PC aborts programming. I have no idea how to force reboot.

            I have also tried force flashing via autoexec.ash
            "firmfl prog firmware.bin > progress.txt
            rm firmware.bin
            rm autoexec.ash
            poweroff"
            but it goes max to [4l...

            With this method the cam generates some files:
            nvd.0 and nvd.1 and progress.txt
            and folders MISC (itm.bin inside) and DCIM
            Last edited by DigY; 04-02-2017, 05:29 AM.

        • #13
          hi there,

          I took the

          26L

          and did
          Unpack, rename to 'firmware.bin' and put to the root of your memory card.

          And now it goes bip bip bip - bip bip bip - bip bip bip - bip bip bip - bip bip bip - bip bip bip - ovver 5 minutes now - how long I have to wait and what to do now?


          Cheers....

          EDIT: UPPS forget to unpack!... now its better....
          Last edited by Xiaomiau; 05-13-2017, 10:29 AM.

          Comment


          • #14
            Hi, this is a simple firmware update or is a firmware update with script?

            Comment


          • #15
            Hey Nutsey,

            I have YI cam Model Z22L it is bricked can you send me the ELF files for the latest firmware, it tried flashing it before with ver 1.2.13 but it didn't work

            Regards,

            Comment


            • nutsey
              nutsey commented
              Editing a comment
              Hi,

              I don't have any ELFs for the latest firmware, but I have older 1.2.6 for Z22L. Have you tried flashing it?
          Working...
          X