Announcement

Collapse
No announcement yet.

Ambarella iOne

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ambarella iOne

    I found Logitech TV HD camera, which runs only Skype. I was buying it for my daughter and my parents of mine who are living far from us.

    Back in 2016 Microsoft and Logitech decided to abandon this project and basically it's not working since that time (it simply don't connect to Skype).

    I have couple of these devices and what to try hack them.

    What I did:

    1) captured traffic with sniffer which is generated by device when connected to internet. I found it was not able to make ping request www.skype.com
    2) I found some suggestions online that fix is to make that pings possible, then connection works! I've added DNS spoofing record for www.skype.com in my internal DNS server and restarted device. It worked and connected to the Skype network.
    3) Scanned IP with nmap for any ports open (none are open).
    4) Tried to start device with "reset" button pressed (to check if it will start in some "recovery" or "firmware update" mode), after that trick it shows Logitech splash screen and reboots in cycles (fortunately I have one more devices same as this one and it's still booting).
    5) I put device out of that plastic box and made photos https://drive.google.com/drive/folde...ns?usp=sharing
    6) In traffic dump I found so far is user-agent string from http client inside
    Dalvik/1.4.0 (Linux; U; Android 2.3.3; Ambarella BOSS Build/GRI40)
    7) Also device is listed there https://wikidevi.com/wiki/Logitech_TV_Cam_HD

    And information on vendor's website https://www.ambarella.com/news/ambarella-ione-camera-applications-processor-enables-a-new-class-of-android-based-smart-cameras/

    Need help to get shell access to this camera.
    Attached Files
Working...
X