Announcement

Collapse
No announcement yet.

Andoer C5 - can't save or restore settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Andoer C5 - can't save or restore settings

    Hello,

    I was searching for any help and I found this forum. Maybe someone could help me. I have few problems with my camera:

    1.) Date/time reset itself after few hours.
    2.) Any setting I do are lost when I turn off the camera. When I turn on again, some setting I did before are loaded (no default settings).
    3.) Resetting camera using "Defaults" option in menu do nothing. Camera will restart but my own settings are loaded.

    I did some initial setting like video, photo resolution, loop recording, auto power off ....few days ago. These setting are permanently saved in camera and any further changes are not saved and in addition factory setting cannot be restored.

    Please help. Is there any guide to reset camera? I attached getinfo log file.
    Attached Files

  • #2
    I've heard flashing ThiEYE T5 firmware can solve this problem.
    Donate here if you want to support my efforts and this site.

    Email me if you have any offers, requests or ideas.

    Comment


    • #3
      According user interface T5 has the same menu as C5. It there any way how to backup C5 fw? I havent found any tool that could do the backup. And I would like to backup if something gets wrong. Can you help me pls?

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        Your camera might have telnet access enabled. So you can simply use dd to backup mtd partitions and then truncate tailing bytes.

    • #4
      Nutsey. Sorry Im little bit lost . What do you mean by "dd"? Can you tell me more details. Step by step.
      I have experiences with Eken cameras and firmwares, but this is different.

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        @ThePegass
        1. Google 'how to enable telnet in windows' and follow the instructions,
        2. Connect your cam to your PC with wi-fi,
        3. Go to wireless connection settings to find out your camera IP address,
        4. Press win+r and run 'telnet your-cam-ip' command, standard Linux console will appear, login with 'root'
        5. Your firmware partitions should be located at /dev/mtdblock0 - 9
        6. Copy each file with 'dd if=/dev/mtdblockX of=/tmp/SD0/mtdblockX' command, where X = from 0 to 9.
        Now you have semi-products of your fw backup. You'll need to truncate tailing bytes, reconstruct headers and pack partitions into one file.

    • #5
      WARNING WARNING

      Doing this has a potential to brick your camera! I mean I knew that but this thread has no warning of any kind about this. I've also seen this idea to use a ThiEYE T5 firmware on the Andoer C5 suggested on some other forums that I don't remember now, and possibly some Russian language forum.

      So has anyone tried this actually? Maybe I did something wrong but I copied the T5 firmware.bin to the card and powered it on. It showed the live view for half a second and then probably started loading the new firmware, the screen went black and I think the LEDs were both on and it didn't change for another 10 minutes. Now it won't power on. It seems like the charging still works but as soon as I press the power button it locks up.

      Any idea for another firmware to try? Since I've got basically little to lose at this point. I'll see if I can recover it.

      In the meantime I don't advise anyone try the T5 firmware as was suggested, until at least one person on any of those forums can confirm that this has actually worked for somebody.

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        Thanks for reporting this problem!

    • #6
      Ok so false-alarm. Apparently the T5 firmwares do work if you flash them from the PC and luckily they made the bootloader brick-proof.

      For the record I went back to that russian forum (4pda) and through google translate found that people actually do this, someone mentioned the 17/02/28 version. The versions currently available on thieye.com are 18/01/19 and 18/06/01 but you can find backups of at least five 2017 versions in this thread. I installed 17/02/28 and it worked, with an identical menu to the original Andoer C5 firmware plus superview resolutions and settings are actually saved over power downs and ups. Upgraded to 17/06/28 (TI/UN7-170628-V5.0), then to 18/06/01 (TI/UN7-180601-V5.1). The V5.1 version has a completely new menu, kinda nice but it removed the 1920x1080 30P superview option (most other resolutions were there, only a few were missing). Downgraded to the TI/UN7-180119-V5.0 and this works and has everything, old menu layout. I'm not sure what the difference is between the UN5 and UN7 versions, someone mentioned it had to do with the dual vs. single microphone. Voice recording worked with all the versions I tried although the 18/06/01 one seemed more noisy.

      For the record you can unbrick the Andoer C5 camera by doing the following:
      • Borrow a windows machine
      • Install DirectUSB from the firmware .rar file
      • If it's 64-bit Windows 10 reboot to the boot options menu and disable firmware signature veriication
      • Install the 64-bit ambarella driver from this thread, download requires that you're logged in
      • Load DirectUSB, select a12evk, load the .elf file, connect the camera holding the UP button and flash the firmware
      • Unplug the camera, remove battery to force a reboot

      Comment

      Working...
      X