Announcement

Collapse
No announcement yet.

AE / AFT vs GoPro HD2 firmware

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AE / AFT vs GoPro HD2 firmware

    Hi !

    For fun, i've tried to hack my old H2 cam's firmware... basically in order to increase the bitrate from 15 to 18 Bbps.
    Here is the link : https://software.gopro.com/Firmware/...2-firmware.bin

    With AFT and the trick that to prevent "BitrateTable not found. Invalid PRI partition or pattern mismatch!" message you have to use 5267376 as custom offset i've been able to edit, modify and recompile the firmware. But as it as shrinked from 51 to 15 Mo i've been affraid to use it
    I've tried to just open, extract and recompile it... as "expected"... I had the same shrinking effect

    So, as Nutsey shows me another tool, i've tried to open it with Amba(rella) Extractor.... Well, since the 1st step i have this issue :


    Any idea on those issues ?

  • #2
    Try running this command from autoexec.ash:
    Code:
    firmfl gen 1 pri d:\pri.mod
    Then Tools-Bitrate-File-Open in AE.
    Donate here if you want to support my efforts and this site.

    Email me if you have any offers, requests or ideas.

    Comment


    • marsu66
      marsu66 commented
      Editing a comment
      Hum, my main issue is not to open the pri file to modify bit rate (it was "one of the goals") but understanding why with aft i was loosing more than 35 Mo from original firmware (an hypothesis could be "the part to manage extension bus for wifi, screen, ....) with AFT and why the same firmware was not openable with AE....

      But thanks for your command....i'm going to study deeply the firmfl command....
      By the way, why just saving PRI file (event if birate is in it) as my goal is to rebuild the complete ?

      Thanx

    • marsu66
      marsu66 commented
      Editing a comment
      For curious (as me) users, by using firmfl gen > d:\list.txt i've get the options :

      Usage: gen [number of partition] [bst] [bld] [pri] [rmd] [rom] [dsp] [filename]
      Ex: gen 3 bld pri dsp d:\amboot_kernel_dsp.bin

      and for firmfl , valid targets are:
      prog
      prog_only
      prepro
      postpro
      gen

      so i think that you were suggesting me to modify just the pri and use prog option to reupload it into the cam ?
      Last edited by marsu66; 10-16-2016, 04:48 PM.

  • #3
    In order to manipulate I've used your command... then i've compared the pri generated from the cam et the one from the firmware extracted from AFT => they are different even if i have verified that the firmware version was matching (HD2.08.12.312.WIFI.R68.02)

    So i've opened the one generated by autoexec with AE.... it works fine.... but it doesn't open correctly on AFT even with the trick given above.... values are.... sensless

    Hum it's getting more and more illogical for me....

    Comment

    Working...
    X