Announcement

Collapse
No announcement yet.

Tool for unbricking A12/A9/A7/A5 based cams. AmbaUSB for ELF/BIN firmware update from PC.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tool for unbricking A12/A9/A7/A5 based cams. AmbaUSB for ELF/BIN firmware update from PC.

    Package includes Ambarella EVK Firmware Downloader tool and Ambarella Evaluation Board driver (disable driver signature verification before installing).

    AmbaUSB v3.4.8 32bit: https://drive.google.com/file/d/0B4t...ew?usp=sharing
    You can use this tool with 64-bit Windows systems. Install this driver Ambarella-driver-64bit.zip after running AmbaUSB tool setup file (check 'readme.txt' and run 'install.bat').

    AmbaUSB v3.3.1 32bit: https://drive.google.com/file/d/0B4t...ew?usp=sharing
    AmbaUSB v3.3.1 64bit: https://drive.google.com/file/d/0B4t...ew?usp=sharing

    This tool replaces DirectUSB and its driver.
    Last edited by GoPrawn; 10-27-2016, 01:29 PM.
    Donate here if you want to support my efforts and this site.

    Email me if you have any offers, requests or ideas.

  • #2
    Hi friend, thanks loots for this post. is the only one in all internet i found what have sowed me that exist a bit light at end of the tunel! im no too much good with softs,,
    but today i make the big mistake to try to update the firmware of my new cam.
    (all this was becouse the camera was not woking good, it frezzes some times, and also have missing options like the 720p resolution)

    well i wi ll try to explaind abit what was happen, download from the facebook of eken the las firmware for the h8Pro , and make the process to put in to a the sd card an all this,,
    i put into the cam and the camera sey if i like to update firmware, until here all good. after wait like 30 min,, i se my camera is just Brick , look like i put the wrong firware on it.

    After some research , i found my camera looks like the hs8 Pro , but because all goes wrong, my camera seems to be a clon of the model H8s .

    Then i belive is for this reason all thiis is happen. i spend this las 5 hours on internet ting to found a solution , but i cant find nothing,, any info or any video bringing back of a brick one H8s ..

    i belive the tools of the post on top will be part of the solution (i hope) ,but i have not idea how i need to proces.. Also i see the programs are for windows (PC) and i have not any one at home, only MAC. ,, but hey! if is gona work i can found one PC easy.

    Well for a bit more problem for me,, i also cant find a specific firmware for the H8s , i see you post 2 diferent firmwares in here , but they are for the H8Pro and H8Plus .. (may be the one of the Plus is going to work for me??).. well.. i feel im close to find of somethink, but at same time i feel farr away to have the camera working again.

    i will thank you alot if you can finish to push me in the right direction for fix the camera and finish with this nightmare. Was a spensive one and i just can not belive i breake it

    some info of my camera: (and proabaly part of the foult of i make the mistake, beocuse is a bit confusing)

    were i buy the camera , the title was:
    H8S 4K UHD WiFi Action Camera - EU PLUG BLACK
    Ambarella A12S75 Chipset 170 Degree FOV 2.0 inch Screen IMX Sensor with 2.4G Remote Controller

    and in specificaitons it sey:
    Model: H8 Pro
    Type: Sports Camera
    Type of Camera: 4K
    Chipset Name: Ambarella
    Chipset: Ambarella A12S75
    Max External Card Supported: TF 64G (not included)
    Screen size: 2.0inch
    Screen resolution: 320x240
    Becouse it seys " Model: H8 Pro " was the reason why i try to intall the firmware of the H8Pro, but clearly looks is not his one. BUt i was not able to found one firmware for the H8s on the facebook page of the eken download firmwares. Just confusing..

    here one foto of the model:


    i dont wan to put any link, becouse dont wan to look like spam or something, but if it will help i can provide all the info and links needed.

    Thanks loots in advance for any help you can guive me friend. And sorry for my long post.

    a gretting
    Last edited by _sOnGoKu_; 01-10-2017, 01:00 AM.

    Comment


    • #3
      Hi Nutsey thanks for the program. Is it possible to use the same ".ads" file for the board config in the H9 Plus as in the H8 Pro? Or are they different? Thanks.

      Comment


      • #4
        Nutsey,
        Says to delete DirectUSB (or does it automatically). Assume this has to do with "driver signing" problems with AMBA devices not being recognised?

        Comment


        • kuyamoto
          kuyamoto commented
          Editing a comment
          amba not displaying my device how can i fix it ?

        • nutsey
          nutsey commented
          Editing a comment
          The software for Sunpus/iCatch cams is called 'FRM', but you need to get the right fw first.

      • #5
        my Win 7 cpu put up a warning against the driver of the 64bit install. saying it was unknown, has anyone a similar remark?

        Comment


        • petesimon
          petesimon commented
          Editing a comment
          yes. it's normal. you must first _disable_ windows driver signature enforcement crap

      • #6
        I had a bricked sj7, this tool works, unlike the direct USB failure on sjcam's website!
        thanks nutsey!
        Last edited by TwoBlues; 11-25-2018, 11:45 AM.

        Comment


        • #7
          https://drive.google.com/file/d/0B4t...ew?usp=sharing - when installed on the computer gives an error(

          Comment


        • #8
          libusb-win32 Ambarella evaluation board devices - installation failed (установка не выполнена)

          Comment


          • #9
            misha1927
            Всё просто. Надо сделать так. Запускаешь установку. После этого она открывает 2-ое окно для установки драйвера. Ничего не делаешь. А идёшь да диск установки "C:\Program Files\Ambarella\AmbaUSB" копируешь от туда папку "driver" в другое место потом открываешь её там (куда скопировал) И запускаешь там файл "dpscat.exe". Он запустится и всё. Потом запускаешь файл установки драйвера "dpinst.exe". Он установиться. Только после этого ты продолжай установку которую остановил. То второе окно засекёт что драйвер уже установлен и скажет что всё ОК.
            .. думаю разберёшся

            Comment


            • #10
              I successfully UNbricked (recovered) an Eken H6s and an Eken H5s Plus after having tinkered too much and stuffed up the original factory firmware. Download AmbaUSB software from - http://pc.cd/iap7

              Code:
              * Notes for doing recovery and unbrick Eken H8Pro/H5s/H6s/V50/etc
              * Ambarella A9/A12/H22/etc camera
              * Tested and worked on Eken H6s and Eken H5s Plus cameras.
              -- Must use real Windows 7, 8.x, or 10, 64bit. Not VM. Not Wine.
              
              Follow these steps, in order, one-by-one. Do not skip any steps.
              
              1. remove USB cable from camera, remove battery, remove SD card from camera
              1a. insert SD card in computer, delete ALL files from SD card
              
              2. reboot Windows, DISABLE DRIVER SIGNATURE ENFORCEMENT
              -- YOU MUST DO THIS ALWAYS
              -- also disable anti-virus software if you encounter problems
              
              3. download CORRECT firmware .ELF file with CORRECT version for your camera.
              -- do NOT use the latest/newest firmware. it may not work.
              -- firmware .BIN file may NOT work
              -- use the latest Peazip, Winrar, or 7-zip https://www.7-zip.org to open .rar and .zip files
              
              -- H6s https://my.pcloud.com/publink/show?code=kZQv1I7ZR8awxnWpQd0KdIfr4sBJUkhsw9HV
              
              -- H5s Plus (not regular) https://my.pcloud.com/publink/show?code=kZiqIn7ZKCEQIUMdtLLwdaYCtCMdfL4RD9lV
              
              -- V8s https://yadi.sk/d/FshctXkSmo8Rdw
              
              -- H5s (regular, not Plus) https://my.pcloud.com/publink/show?code=kZ8lOo7ZySTGT8e93IyDwX4rxRc7OhbDUVzy
              
              -- V50 Pro (NOT Akaso) https://yadi.sk/d/G4spapk1r4DMMw
              
              -- Hawkeye Firefly 8S (NOT 8se) http://pc.cd/Sc6ctalK
              
              -- ... ask me for other firmware ...
              
              4. install software "AmbaUSB-win64-Qt5-Win7-3.6.4-Setup.exe" from http://pc.cd/iap7 or from https://is.gd/bRve3X
              -- do NOT open/run it. only install it for now.
              
              5. answer YES when you see "install this driver software anyway"
              
              6. start AmbaUSB software in administrator mode, right click and "Run as Administrator".
              6a. Change Log Level to "Debug". Change Board's Config to "A12.LPDDR3.EMMC". Click on ✓ "Verify".
                  Do NOT click Find button next to Board's Config.
                  Change chipset name to correct chipset that you have, next to the blue arrow.
                  Many Eken cameras use Ambarella A12. This is called "S2L(A12)".
                  Do NOT click "Read PTB". It is not needed.
                  Click Find button next to "Firmware". Open the CORRECT .ELF file with CORRECT version.
                  For example, "bst_bld_pba_sys_dsp_rom_lnx_rfs.elf" file is for H5s Plus STD_EKIK_20180426.
                  Your .ELF file may be different.
              
              7. remove battery if not already. press and HOLD shutter/OK button on
                 camera first, then connect USB cable to camera and to computer USB 2.0 port
              -- USB 3.0 port may cause problems
              
              8. if all steps 1 to 7 are done correctly and completely, then click
                 big blue down arrow in AmbaUSB software.
              
              9. You must see "amba_usb_firmware_session.cpp" messages in the log box. Log Level is Debug.
                 If you don't see that, then the flash download may fail.
              
              10. You must see "amba_usb_device_manager.cpp: Firmware session 0x012345 has finished transfering!"
                  messages in the log box. Log Level is Debug.
                  If you don't see that, then the flash download may fail.
              
              11. remove USB cable from camera. Close AmbaUSB software.
              
              12. insert battery, insert SD card, power on camera. Open Settings menu,
                  go to Reset, choose Yes. Power on camera again.
              .

              * Updated instructions (Word DOCX document) - https://drive.google.com/open?id=1xm...7C1kDQIY5iDD85

              More related data - https://is.gd/bRve3X

              click on the small image.
              Click image for larger version  Name:	AmbaUSB-Eken_H5s_Plus-USB-connected-options.jpg Views:	3 Size:	208.0 KB ID:	15331
              Last edited by petesimon; 12-18-2019, 06:50 AM.

              Comment


              • petesimon
                petesimon commented
                Editing a comment
                If you have 32bit Windows, then download "AmbaUSB-win32-Qt5-Win7-3.5.8-Setup.exe" from the link written above.

              • petesimon
                petesimon commented
                Editing a comment
                for Ambarella Firefly 8S or 8SE, remove battery, remove sd-card, press and hold the RIGHT / FORWARD button when connecting the camera to computer via USB cable. Other cameras may need different button(s) to be pressed to enter recovery mode.
                Last edited by petesimon; 10-23-2019, 12:26 PM.

              • Adelflavio
                Adelflavio commented
                Editing a comment
                Olá, o link do H6S esta quebrado, tem como conseguir?

              • petesimon
                petesimon commented
                Editing a comment
                Adelflavio - fixed. H6s fw - https://my.pcloud.com/publink/show?c...fr4sBJUkhsw9HV

              • TwoBlues
                TwoBlues commented
                Editing a comment
                Great post petesimon:This will help many!

              • petesimon
                petesimon commented
                Editing a comment
                An augmented / improved version of the 'howto' document by Grunta - online Google Docs - https://is.gd/unbrickambarellaa12cameras

              • petesimon
                petesimon commented
                Editing a comment
                Xiaomi Mijia 4k action camera, firmware - http://pc.cd/2XT7 - look for a bin-elf file

              • kuyamoto
                kuyamoto commented
                Editing a comment
                my diveice is not showing on my amba

            • #11
              For the SJCAM SJ8 Pro (not plus), a very similar process should work.

              Click on the small image.
              Click image for larger versionName:	AmbaUSB-upgrade-via-USB-SJ8Pro.jpgViews:	0Size:	211.5 KBID:	15344

              Download tools and firmware .ELF file for SJ8 Pro. - https://my.pcloud.com/publink/show?c...43M767yjVUNBke
              - Read instructions inside the downloaded zip or rar file.

              Afterward, install another firmware .bin file from sd card https://my.pcloud.com/publink/show?c...k3OTaVsJe6eii7

              Source - http://support.sjcam.com/support/sol...ro-usb-upgrade
              Last edited by petesimon; 08-28-2019, 01:28 PM.

              Comment


              • #12
                Hi, i tried to unbrick my Firefly 8s, but i have some problems...
                If i try without battery, pressing up button, it don't start
                I have to press the starting button, and the program find all, but at the end, failed to reboot§Same thing with bettery inside
                Help, please!!!

                Comment


                • petesimon
                  petesimon commented
                  Editing a comment
                  do you have a FF 8S or a FF 8SE ?

                  look at post #10 again (link here). read all steps again. do steps 1 to 6a normally. follow and do steps slowly. no rush.

                  but on step 7, try to press and HOLD the Down/Left arrow button _or_ the Up/Right button and connect your camera via USB 2.0 (not 3.0) port on computer. Use a good quality USB 2.0 cable. Try another camera button if your first attempt didn't work. Holding a camera button before connecting via USB is necessary. Windows 7, 64 bit edition might be easier than Windows 8.x or 10 to use for unbricking a camera.

                  use the latest 7-zip or Winrar software for .zip .7z and .rar files. * must always disable driver signature enforcement in Windows.

                  you can contact me directly by FB messenger at http://m.me/psvangorp or at http://fb.com/psvangorp or contact me via email petesimon (at) yahoo.com , change (at) to @
                  Last edited by petesimon; 04-01-2020, 05:45 PM.

              • #13
                Some .elf files for Eken cams

                https://tinyurl.com/rhw3mgy
                Last edited by Grunta; 12-27-2019, 02:23 PM.

                Comment


                • nutsey
                  nutsey commented
                  Editing a comment
                  Please recheck your link.

                • petesimon
                  petesimon commented
                  Editing a comment
                  *EDIT* thanks G
                  Last edited by petesimon; 01-12-2020, 07:51 AM.

              • #14
                Hello...I have mijia 4k..My device has bricked after

                ​install latest firmware...I try to teardown my device..But I think not from hardware...I try to flash with Amba usb software but my device not detect in usb....still not recognised
                ...please help....

                Comment


              • #15
                Click image for larger version

Name:	20200414_184123.jpg
Views:	1612
Size:	827.2 KB
ID:	17611Has anyone successfully recovered a Xiaomi Mijia actioncam ?

                Comment

              Working...
              X