Announcement

Collapse
No announcement yet.

Campark x20 won’t boots

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Campark x20 won’t boots

    Hi I bought a campark x20 and it seems that it’s stuck in a loop when it boots up just shows the picture of the skier and campark logo but won’t go past that screen, does anyone know a fix for this? I will link the product I bought.

    would really like to get this fixed as it’s a present

    thanks

    https://www.ebay.co.uk/itm/182775541936

  • #2
    Did it work before or it came already faulty?
    Donate here if you want to support my efforts and this site.

    Email me if you have any offers, requests or ideas.

    Comment


    • #3
      It cams faulty and seller is horrendous at replying

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        Campark X20 has at least 3 hardware versions with different CMOS sensors inside and these firmwares are not compatible to each other. Moreover an updated X20 version has totally different hardware platform. Does it have any s/n or other markings on its package?

    • #4
      There is nothing on the box but it says in the booklet 1/2.3 SONY CMOS Sensor with a NT 96660 chipset

      Comment


      • #5
        If it is faulty, I would honestly recommend returning or opening Paypal claim. Especially if the seller does not reply.

        Comment


        • #6
          The seller replied but wasn’t very helpful took them 4 days to reply

          Comment


          • #7
            Does anyone have the firmware for these camera?

            Comment

          Working...
          X