Announcement

Collapse
No announcement yet.

Explorer Elite 4K -hard bricked firmware

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Explorer Elite 4K -hard bricked firmware

    Hello.I had a big problem with my camera,don't startup does not boot.When I plug on my computer is not recognized, with battery removed, sd card removed and plug to power source
    just flashing red light. it's 100% bad FW flash bin file.
    Is there a way to fix it?

    I have ELE Explorer Elite 4K cam with NTK9660 chipset , It says L1027 660_key2 20160318 on green PCB.

  • #2
    Put a previously working firmware file on the sdcard root and power the camera. As long as the bootloader isnt corrupted it should be recoverable that way

    Comment


    • nutsey
      nutsey commented
      Editing a comment
      I suppose the loader needs to be recovered here first.

  • #3
    I think I need to recover bootloader, is there a way to do it?

    Comment


  • #4
    i have the same problem with my NEW EXPLORER ELITE 4K! Any solutions that finally worked?

    Comment


    • #5
      Hi, did you manage to fix the issue of your action cam? I have totally the same problem as yours...mine is the very first version of Elite 4K. I was trying to flash the firmware shared here:

      https://www.goprawn.com/forum/action...e-20170208v1-0

      and yeah..it failed and bricked...I have tried many ways to fix it (flashing back old firmware, loader and firmware files that shared by someone and latest single firmware file) but none of it successful. Kindly share the method if you have successfully fixed it. Thanks!

      Comment


      • #6
        Bump Bump Bump

        Comment


        • petesimon
          petesimon commented
          Editing a comment
          thump thump thump

      • #7
        Hello guys I have contacted elphone ingineers and they send me this link to al firmware lets try them https://mega.nz/#F!U0QnmIxI!MuaR0PddfjF9Odr83yeUKg

        Comment


        • #8
          fix brick camera
           

          Comment

          Working...
          X