Announcement

Collapse
No announcement yet.

Akaso V50 Pro Bricked after Firmware update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Akaso V50 Pro Bricked after Firmware update

    Hi there

    I seem to have fallen victim of a botched firmware upgrade. It seemed to have gone OK but the camera now only turns on to a blue fixed led light and no screen. After turning on, I also can't turn the camera off using the buttons, I have to remove the battery.

    I've tried to update the firmware using the software that's been discussed for the iCatch v50 SoC. However, I can't seem to get the camera to enter into recovery mode. It is never recognised as an USB device. I've followed the steps below but step after step 5. I still don't have a USB connection with my desktop.

    Recovery mode is possible by doing these steps on the camera, in the same order as you see here:
    * First disconnect any usb cable from the camera, and power OFF the camera

    1. install " icatch_v2000.exe " drivers file to your computer. download it here - http://pc.cd/dNVrtalK
    2. REMOVE BATTERY from camera. very important!
    3. be sure that a USB cable is not connected first, and press and HOLD OK (shutter) button
    4. connect usb cable to camera and computer, while still holding OK (shutter) button
    5. continue to hold OK (shutter) button, and press the power (mode) button one time.
    6. you should see two new sunplus icatch usb devices in Device Manager (now release all buttons)
    7. See this PDF file - http://pc.cd/NOk
    8. continue as per the instructions in the Thieye firmware zip or rar file.
    Have you experienced a similar issue? How can you get the camera to show up in Device Manager? Given that it's the same iCatch V50 chipset I'd have thought that it'd behave the same way.

    Thanks everyone.

  • #2
    recovery of the Akaso V50 Pro (touch screen) or MGCOOL Explorer 3 (V50, touch screen) may not be available by pressing buttons and connecting an usb cable.

    contact Akaso directly

    https://shop.akaso.eu/contact

    [email protected]

    [email protected]

    https://www.facebook.com/akaso.official/

    Phone Number: +1-301-670-7335 (USA)

    Comment


    • #3
      Thanks Pete. I've been in touch with them. However, as I'm based outside the US they suggesting no support and only offering partial refund only. Quite odd as cameras as sold worldwide. There is no geographical restriction for sales and their own warranty information excludes any geographical limitations.

      I've since been made aware that there are several versions of the camera. Therefore, firmware updates don't work for all of them. Quite dangerous to publicly release firmware updates that will break certain versions of the cameras without people knowing.

      Thank you.

      Comment


      • petesimon
        petesimon commented
        Editing a comment
        all very true. these low-end chinese camera companies are very good at marketing/advertising/sales and sometimes good at releasing firmware (but without enough technical information about the firmware), BUT the same companies are terrible at support.

        in June this year, the "worth it or not" reviewer had the same trouble as you, shown in this video - https://youtu.be/r3wNSiDNuyg

        However, SJCAM is a good example of a very good chinese camera company.

        by the way, have you tried any of these firmware files?
        - http://akaso.net/firmware/AKASO_V50_Pro_20180802_V4.rar || http://pc.cd/CNq
        - http://pc.cd/nKErtalK
        - http://pc.cd/hWJ
        ?

        also see my post about the MGCOOL Explorer 3 (Akaso V50 Pro clone) - https://www.goprawn.com/forum/sunplu...0916#post10916
        Last edited by petesimon; 09-29-2018, 02:07 AM.

      • h_ramus
        h_ramus commented
        Editing a comment
        Thanks. I've obsessively investigated, watched and reviewed several videos and posts about action cameras being bricked and recovering them. I watched that video as well, thanks. It seems that the Akaso v50 pro doesn't have a recovery mode the same way that a ThiEye or similar iCatch V50 cameras have. I can understand now that some people are getting them bricked whilst others are fine. It's down to the different versions of the camera. I have an April version, you can see it from the sticker on the battery flap. This version also doesn't support an external microphone. Newer versions support the external mic and the firmware updates being released seem to cater for these rather than old models like mine.

        I've downloaded multiple firmware versions to try and update it. The sd-card update method also doesn't work at all. Also, I can't seem to connect the camera to a PC hence trying to see if there's some special way to put this camera into recovery mode. I seem to be out of options.

        Akaso have since confirmed that if I place a new order they'll issue me a full refund. I guess I'll bite the bullet as the camera was quite decent for me albeit low light and 1080 performance was passable. I hope they don't "forget" to issue the refund but they seem to be finally be honouring their warranty guarantee. Fingers crossed.

      • AussieKev
        AussieKev commented
        Editing a comment
        Yes 'Worth It Or Not' (Andre) did have f/w problems but luckily lives in USA with buyer protection from Amazon. They are NOT available for shipment by Amazon (USA) to Australia or available on Amazon (dot) au (Australia) either. Thankfully it seems!
        Last edited by AussieKev; 03-15-2019, 07:58 PM.

    • #4
      Hi, Ramus,
      Have you already met these firmwares (first from 08.29, second one 11.16):
      https://www.amazon.com/clouddrive/sh...ERVxJyE6zc00fY
      https://www.amazon.com/clouddrive/sh...iPC0IFNEzTYmuL
      I got them from Amazon to upgrade my (working) camera labelled TJTSP20180411, with existing partially working (no H.265) firmware V50 Pro TJTV1_05162018. As your cam is already bricked, try them and inform us about the result!
      Last edited by jolaca; 01-11-2019, 06:16 PM.

      Comment


      • petesimon
        petesimon commented
        Editing a comment
        Thanks jolaca . I see that you have commented on my post.

        Yeah, so... I have an " MGCOOL Explorer 3 " and I'm successfully using Akaso TJT08022018_V4 firmware. H.265 option is available. Akaso firmware provided more options than the default MGCOOL firmware. See this post here.

    • #5
      Originally posted by jolaca View Post
      Hi, Ramus,
      Have you already met these firmwares (first from 08.29, second one 11.16):
      https://www.amazon.com/clouddrive/sh...ERVxJyE6zc00fY
      https://www.amazon.com/clouddrive/sh...iPC0IFNEzTYmuL
      I got them from Amazon to upgrade my (working) camera labelled TJTSP20180411, with existing partially working (no H.265) firmware V50 Pro TJTV1_05162018. As your cam is already bricked, try them and inform us about the result!
      Hi Jolaca

      Thanks for getting back to me and apologies for the belated reply.

      An update on my situation. Akaso honoured their commitment and sent me a new camera whilst refunding its cost. I now have a normal working camera (that I'll never update!) and a bricked one.

      I have the same model camera as you, TJTSP20180411. I've tried both files you've posted but no success. My problem is that the camera doesn't boot up at all hence the sd-card firmware update method doesn't kick in.

      I'd imagine the only option left would seem to write directly into the ROM (or wherever the firmware is currently saved). Without having a direct replacement of the current firmware on my camera I can't get it to boot. It only shows a blue light and doesn't turn off when pressing the power button.

      Is there any way of re-writing the camera firmware directly?

      Comment


      • petesimon
        petesimon commented
        Editing a comment
        congratulations. the bricked camera can very possibly be recovered by using some undocumented key presses, using FRM.exe software, or disassembling the case and attached some electronic tools such as an "SPI flash programmer" to the NAND (ROM) chip 🤓. I've never done that but some youtube videos may be available for that.

        Will the bricked camera respond when connected to USB on a computer? - maybe first press some buttons as noted at the to of this page.

      • h_ramus
        h_ramus commented
        Editing a comment
        The bricked camera isn't recognised as a USB device on my laptop (ubuntu based, lsusb doesn't list it). I've tried the button combinations suggested here and for other cameras. My guess is that the camera usb controller is not started as the ROM version is wrong.

        I've taken the front plastic cover apart and exposed the chips. However, I think that writing the ROM chip is beyond my capabilities as it'd involve tools I'm not familiar with.

        Thanks for your suggestion. I think this one went the way of dodo. Other than directly flashing the ROM it'll stay a paperweight.

    • #6
      Hello everyone!

      ...another owner of the Akaso V50 Pro here (TJT20180816_V4)

      It's my first action cam but after a few days I don't think it was a waste of money.

      ...exept form they fact that Akaso should add a protection cap, a screen-off-function and a downloadsection with different firmwares...

      Now that I found this wonderful little place here and V5-Versions of firmware - should I give it a try?...don't want to brick my cam as well

      What will it do.....is there any changelog available?

      And what about the SE-Version of the cam?

      Can't buy it from outside of the US....but is there a chance that it's firmware could upgrade the "normal" Pro to 4k/60, 1080/120, raw ,....?

      Would be a dream....but where to get it?






      Comment


      • petesimon
        petesimon commented
        Editing a comment
        official Akaso "V4" firmware should work. and there is a small chance that "V5" firmware would work for your cam.
        * but don't flash any firmware, unless you're very sure that you are willing to take the risk of brick'ing the cam

    • #7
      Hello everyone,

      Thanks to all who posted on this great thread. I just purchased one of these cameras from Amazon, and I had a mighty bad time with it until I found this thread. To summarize:

      0) Straight from the box, H.265 did not work: the setting was there, I selected it and the camera accepted it, but all recorded movies were encoded in H.264 (ie, the camera 'lied' about accepting the H.265 setting, and instead "silently ignored" it and continued to encode in H.264).

      1) I then contacted Amazon support, and they quickly opened a ticket for me with Akaso; Akaso then contacted me and, after me some back&forth, sent me a link to their V6 firmware, which I now provide for your enjoyment: 20181205_V6. BEWARE: this V6 firmware is know to disable the touchscreen at least in some hardware versions of this camera (see below), install at your own risk!

      2) I installed this V6 firmware, and H.265 started working, *but* with the very unfortunate side effect of disabling the touchscreen: it simply stopped reacting to any touches, which made the camera practically unusable as there's a lot of things I can't do using only the physical buttons.

      3) I reported back to Akaso and they said (only then) that losing the touchscreen was expected, as the new V6 firmware was incompatible with my camera's hardware version (which, according to them, would be compatible with the V5 firmware only). I responded that I would have preferred they had warned me of that *before*, as I was then in the middle of a long trip overseas and was stuck with a unusable camera. By the way, my camera's "hardware version" (which I understand is the white sticker on the inside of the battery door) is "TJTSP20180411".

      4) Akaso then offered me to return the camera for refund or replacement; I explained again that I was away from the US on a long trip and it would be quite some time until I returned to the US, and I would therefore unable to return the camera.

      5) Akaso was then very kind and offered me a full refund of the price I paid for the camera *without* needing to return it, which I immediately accepted and they promptly provided; I then used the money to buy a non-descript HD-only camera locally, which ended up costing more than the Akaso on Amazon (tourist prices and all that), but at least I got a camera to film my trip with.

      6) A few days later, I found this thread, and after careful reading, tried updating to two of the firmware versions linked here, with the following results:

      * 08292018_V5: touchscreen got back to working, but no H.265;

      * 111618_V5: touchscreen *AND* H.265 working! Yeah!

      I'm still testing the camera to make sure there's nothing broken, but so far the update seems to have been entirely successful.

      So again, thanks to everyone who posted on this thread, and specially to jolaca for providing the link to the miraculous 111618_V5 that got my camera back from the dead.

      Also, kudos to Akaso for providing me the refund: they were not so great in the technical aspect, but they did everything on their power to make me a satisfied client, and I'm grateful to them for their handling of the situation (and posted a 5-star review on Amazon to that effect).

      Cheers,
      -- Durval.
      Last edited by durval; 03-13-2020, 07:53 PM.

      Comment


      • #8
        durval .. what do card were you using ? (Post a pic of it please)

        ​​​​​​

        Comment


        • #9
          h_ramus ... At the start, you state you installed icatch_v2000.exe drivers (I assume- since you reference it ?)

          1. what windows version do you have ?
          2. Did you disable the windows driver signature ?

          Comment


          • #10
            Hello Grunta,
            Originally posted by Grunta View Post
            durval .. what do card were you using ? (Post a pic of it please)
            You mean "SD card"? I use exactly this one (link w/pictures): https://www.amazon.com/gp/product/B06XWZWYVP (Samsung (MB-ME128GA/AM) 128GB 100MB/s (U3) MicroSDXC EVO Select Memory Card with Full-Size Adapter)

            Hope it helps.

            Cheers,
            --
            Durval.

            Comment


            • #11
              Those green ones... I've seen posts elsewhere about problems
              I suspect poor sustained write speed


              1. Reformat it with guiformat
              2. Test WRITE SPEED with h2testw

              Comment

              Working...
              X