Announcement

Collapse
No announcement yet.

Help to unbrick SPCA6330 camera

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help to unbrick SPCA6330 camera

    Hi Good day im newbie here i just want to ask for your help i think my action camera brick or the OS is deleted how can i install another OS/firmware that is compatible with its chipset iCatch SPCA6330 ? is there any software for computer to directly install it to the camera? please help me i want to recover this camera it is quite cheap but i love it we doClick image for larger version

Name:	92860924_126348502348501_7712111081346301952_o.jpg
Views:	342
Size:	54.1 KB
ID:	17625

  • #2
    Hi,

    What is your camera make/model? What was the cause of the fault?
    Donate here if you want to support my efforts and this site.

    Email me if you have any offers, requests or ideas.

    Comment


    • #3
      thankyou for your reply, i dont know exact model but it is LHR W8 camera and it is a iCatch SPCA6330, i think it is because im tryiing to update its FW and suddenly i download a wrong FW and accidentaly installed it and after its boot the cam turns off and then i tried to open it again but no response even the boot is not on display it is all black but the power indicator is on .. and when i connect it to my laptop this one always comes up on my device manager ...Click image for larger version

Name:	Capture.PNG
Views:	267
Size:	1.4 KB
ID:	17628

      Comment


      • nutsey
        nutsey commented
        Editing a comment
        Do you have a stock firmware for your camera?

      • kuyamoto
        kuyamoto commented
        Editing a comment
        suddenly i dont have but im trying to install other firmware but my device is not showing on amba im looking for this driver but i cant see on any website USB\VID_04FC&PID_6330

      • nutsey
        nutsey commented
        Editing a comment
        Try this tool and driver: https://mega.nz/file/WrwT2BQS#eF84oU...51YhDPIgd1-zBw

        Here is the guide for it. Please note that this fw is NOT for your camera and might or might not work:

        "Fully charge camera's battery!!

        2. Run ISP_v1201.exe in "Drivers" folder

        3. After installation complete, reboot windows, press F8 and choose "Disable Driver Signature Enforcement".

        4. When windows boots up, remove battery and SD card from camera. Press and hold "up" key and connect camera to PC via USB cable. System will found new device and install drivers. Check in device management that drivers set properly.

        5. Run "FRM.exe" in "download" folder. If it shows up "USB device not connected" - that you don't properly install drivers, or do not disabled force driver signature. If it boots up normally, choose "Flash type: SPI", all other leave as is.

        6. Press ISP (F5). In bottom line will be "Check ISP core", then "writing firmware". Wait until it done and shows up "ISP done." Press ok and close program.

        7. Take SD card, format it in FAT32. Copy all 3 files under "SD card" folder to the root folder of SD. Without any folders.

        8. Insert prepared SD card and battery in camera, and power on. Insert charger (do not connect to PC, use AC adapter). If LCD screen fully white or image in green tones - it's normal. Wait 10 minutes, do not touch anything.

        9. Remove battery. Remove SD card. Insert battery and try to power ON. If all done properly, it boots up normally."

      • kuyamoto
        kuyamoto commented
        Editing a comment
        ill try this one sir hope it works thankyou

    • #4
      sir i tried so 3 times the instruction but ithinnk my problem is this driver frm always not detect my device Click image for larger version

Name:	Capture.PNG
Views:	279
Size:	42.0 KB
ID:	17642

      Comment


      • #5
        this is my device
        ActionCam N9
        STD_C4D9AX
        170112

        Comment


        • #6
          there are times that my device is detected and when I start pressing f5 windows sounds like my device was disconnected so the FRM prompt that Check ISP Code error what will I do now ? I saw to on other sites that there maybe a problem when im running FRM on windows 8 is true because my OS is 8.1.

          Comment


          • #7
            Exact same issue. I fought for a few days trying to get the device to come up as a webcam. I saw catch(x) kv series, that it was a 6330 chip and the drivers all load okay. But when I tried using FRM to backup by using the advanced menu, right clicking on RSV and "get", I have the Check ISP error. That causes the camera to disconnect and shut off.
            When I was using AMcap or any webcam software, zoom, OBS, I get a code(10) cannot start device.

            I tried using many other sunplus drivers, newer ones from 2018, modified info files. I couldn't get any to use just "USB video device" driver and work like youtube videos show. Same result with the error "cannot preview graph" or code(10) cannot start error.

            This led me to thinking, maybe the firmware is not allowing USB read/write through to the Winbond chip, why FRM check isp error. I tried so many driver combinations, something should allowed it to be used. Maybe the firmware did not enable UVC video service or include it on its Linux partition? I wanted to primarily use this thing as a webcam since other ones worked okay for me.

            I'm looking into making an SPI connection and use some Arduinos I have, but I've never have done this with Arduino before, though my background is electrical engineering from school, 20 years ago. I'm pretty confident I'll get the SPI hooked up and try to pull a dump from the chip. It's just FRM would not let me do this via USB.

            So I ended up trying to SPHOST.BRN file on the SDCard, it recognized it on boot, went into firmware upgrade, turned off, and that's what I bricked. Never lit up LED or LCD again. However, I can still hold my OK button and connect to PC to get into the USB mode. I just can't get any other response from the camera. The BRN file was a 2018 H8 version from Eken. I thought it would match up to the 6330 chip better and enable more USB video function.

            4k wi-fi camera label

            Software version called it the following:
            ActionCam H9
            89-20-V1
            20180319+EN

            I took it apart now. Photos if you want to see.
            Board stamped 18 13
            SPCA6330A - HB261 1737
            Samsung 348 K4T1G164QF BCE7 memory
            Realtek comms chip ends D30B, can't read the rest.
            AXP192 HA074AXXXX61
            I can't see where to read the image sensor module ID.
            LCD ribbon FPC-PSD200-170 170505FXBL
            Winbond chip (25Q64JVSIQ1751)

            Willing to try and help anything you guys want to learn more on this issue.

            My PC was WIndows 7 -64 bit ultimate. Tried both F8 mode and accepts the prompts on driver install unsigned no problem. I also unearthed a windows XP pro PC and same results..
            Last edited by jmike77; 04-26-2020, 08:09 AM.

            Comment


            • #8
              so there is no other wway sir ?

              Comment


              • #9
                Do you have arduino and willing to open the camera? There is spanish speaking site who shows how to hook up to the flash rom.
                It uses SPI on winbond ic. Mosi miso clk cs from arduino can program it with the bin file that is expected to use under FRM. I wish people would break down in steps what parts FRM puts together and the package building folders that make the sphost.brn. if we knew if it's just transferring the isp file, what blocks, does it also do bootloader or what, then maybe we can concatenate our own full flash to burn right to the blocks via isp.

                I got the arduino spiflash able to read and write with the Russian spieeprom flasher. But i need to repair my bootloader with a clean bin.

                Im trying other firmware that way. But if you have a bootloader that still gets you into debug mode where the device shows in Windows pc, there is still a chance. Mine is fried at moment.

                https://pikabu.ru/story/programmator...rduino_5193861

                https://www.alegorosito.com/sj4000-c...ara-spca6330a/


                Comment


                • #10
                  I found more recent FRM versions and icatch v200x driver in some newer eken zip files. Then i ran directory compare to see what's different between files in A B folders and such. Trying to learn how it packages them up to the BRN file which is able to be extracted using 7zip or rar tools.

                  Comment


                  • #11
                    o man I already saw the site but suddenly i dont have andruino and i dont have any experience doing that thing. but all the images on that site is the same camera as mine i dont lose hope about my camera because of that. maybe some other time i will study about andruino so where I can make some ways to revive it thanks a lot !!

                    Comment


                    • #12
                      Originally posted by kuyamoto View Post
                      o man I already saw the site but suddenly i dont have andruino and i dont have any experience doing that thing. but all the images on that site is the same camera as mine i dont lose hope about my camera because of that. maybe some other time i will study about andruino so where I can make some ways to revive it thanks a lot !!
                      Чтобы установить драйвер для 3 устройств, надо
                      Установить драйвер ISP_v1201. Читай сообщения выше
                      Обязательно запустить Windows в режиме "Disable Driver Signature Enforcement". Это главное условие!
                      После установить драйвера на все устройства из папки "C:\Program Files (x86)\General PC Driver".
                      Извините, но я читать английский со словарем.

                      Comment


                      • #13
                        i already did sir many times but its all not working

                        Comment

                        Working...
                        X