Announcement

Collapse
No announcement yet.

Akaso V50 Pro locking up...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Akaso V50 Pro locking up...

    Hello everyone,

    Regarding my V50Pro I previously managed to revive thanks to this forum (see here), after a few more months it totally locked up, ie: one day it was working, then the next day I turned it back up and it lighted up the screen with the Akaso logo, played its starting tone sounds, and then nothing -- it stayed on this screen forever (1 left it at it for a full hour and it simply kept there), didn't respond to any of the buttons (neither short nor long press) and the only way out was removing the battery. But plugging the battery back in, and turning it back on again, the same thing repeated.

    Of course I checked that the batteries were fully charged (and swapped the battery with another one also fully charged just to be sure), that the SD card was correctly reformatted, also tried with another SD card and even without the SD card, but the same thing remained: the battery simply locked up at the exact same point.

    So, I was just making a video of it locking up (using my phone's camera) in order to upload here and ask for help, and VOILÁ, out of nowhere it unexpectedly worked (after literally dozens of previuos unsuccessful attempts).

    So, now I'm worried that this camera is going to fail again at the worst possible moment (when I'm in the middle of some expedition or trip to somewhere with both incredible views and the impossibility of getting hold of another camera) -- but I'm also loathe to simply discard it as unreliable and buy another camera.

    Therefore, I ask: is there any way to try and recover the camera from such a locked-up state when it happens again in the future? I've seen posts here regarding usage of a program called FRM over the USB cable to try and reflash the firmware, but I do not think this would work (another poster here reported it did not work for him).

    Thanks in advance for your tips and info,
    -- Durval.


Working...
X