Announcement

Collapse
No announcement yet.

RunCam split

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RunCam split

    I have another camera using an iCatch SPCA chipset: The RunCam split.
    Its designed for drone racing so there is a PCB and sensor split. http://shop.runcam.com/runcam-split/
    They have laser removed the iCatch logo and you can not read the partnumber, but it should be the SPCA6350A.
    On the image sensor pcb there is no text at all, don't know what it is.

    Firmware is in .BRN format and parts are equal compared to EKEN H9. RunCam Firmware can be found on this page:
    http://support.runcam.com/hc/en-us/a...rning-Split-on

    The runcam is new to market and there is a common software issue bricking the cam (you will get a new PCB for free)
    In this case one red LED is blinking and nothing else. If you connect the USB it is not recognized, even not in usb device viewer.

    Do you think there is a way to unbrick them? Any debuging or bootmode selction via testpads ?
    Has someone tried flashing the firmware on the SPI Flash manually (using programmer/microcontroller)? Is it a 1:1 image of the firmware file ?
    Last edited by Flori444; 08-18-2017, 12:12 PM.

  • #2
    This camera is based on 6350+OV4689 combination.

    I saw a solution for bricked H9 Eken cams here.


    That guy managed to recover his dead cam with such settings. He flashed stock fw.
    Click image for larger version

Name:	frm.jpg
Views:	409
Size:	60.7 KB
ID:	6110
    Donate here if you want to support my efforts and this site.

    Email me if you have any offers, requests or ideas.

    Comment


    • #3
      I managed to flash a firmware (H9...SY) on the runcam and now it is booting (both leds turn on, the orange LED keeps on) but nothing else.
      How to find out the settings for my hardware ? or is there a way to flash the .BRN file ? SD update with the RunCam BRN image named SPHOST.BRN is not working (and I don't get video output)

      Comment


      • #4
        I tried flashing several H9/H9R firmwares and found the UART output on the testpads on the board, all with the same result. Looks like the initialisation is ok but it stops as the camara is not responding (Error MIPI Clk lane LP state check timeout!)
        Here is the UART log while booting log.txt
        I wonder if its posible to SD Update the firmware somehow. At boot a SDHC card (seems to be detected) with the SPHOST.BRN is present, but its not been checked.
        Whats the difference in all these H9/H9R images/hardware revisions ?

        Update:
        When looking to the SPHOST.BRN file there are some parts in ascii and you find something like:
        spi <option> <para1> [para2] [para3]; Please specify file [addr]...
        Boot File %s 0x%x ISP File %s
        isp To do isp from card...
        isp <firmware bin>
        or isp <*.BRN >
        but there is no cmd "isp". in help (see cmd.txt) only "ispFw" is listet what seems to be the right comand, the output is:

        cmd>ispFw
        Run Card ISP FW
        ---------------------------------------------------
        | |
        | iCatch Card ISP Version [6350.0007] |
        | |
        ---------------------------------------------------
        filePath: D:\SPCA6330.BRN drive:2
        filePath = D:\SPCA6330.BRN
        vfsOpen(596): errcode=fffffecf
        [CardUpdate]err: 0xffffffff

        1. why is there a SPCA6330 file?
        2. seems to be a error with D:\ (sd card?), maybe its not mounted

        Update2:
        Got it working again with A,B,SPC downloaded from a working one.
        Further updates and Howto
        Attached Files
        Last edited by Flori444; 08-29-2017, 02:25 PM.

        Comment


        • #5
          Hi,
          I bought the runcam split too and i had a problem related to the firmware. Can i ask to hel me, please?
          I started to upload the new version of firmware in the manual mode (including the firmware file on the SD card).
          While the camera started to upload the firmware, it powered down and up quickly, after the power up the camera doesn't work, the light 5 red is flashing continuously but the camera doesn't turn on.
          I tried hardware reset (I pressed the WiFi button for three times within two seconds, like in the manual) but nothing works.
          So, I would kindly ask how can I reset and restore my camera and after how can I verify that the camera is restored.

          Thanks a lot!!!

          Comment


          • #6
            Originally posted by Flori444 View Post
            Update2:
            Got it working again with A,B,SPC downloaded from a working one.
            did you use spca6330isp.bin or spca6350isp.bin ?

            Comment

            Working...
            X